Robotrontechnik-Forum

Registrieren || Einloggen || Hilfe/FAQ || Suche || Mitglieder || Home || Statistik || Kalender || Admins Willkommen Gast! RSS

Robotrontechnik-Forum » Technische Diskussionen » RAMTEST3 mit M036 128K » Themenansicht

Autor Thread - Seiten: -1-
000
10.09.2018, 05:06 Uhr
edbru



Hallo,

hab jetzt mal die Leerplatine von Ebay bestückt und soweit ist alles OK.
Ramtest3 mit vorher TESTM 0C gestartet und dann TEST läuft ohne Fehler durch.
Starte ich aber TESTM ohne Parameter zeigt er ordnungsgemäß Slots: 03 04 0C an.
Starte ich nun TEST so läuft der erste Test 00 ohne Fehler, zeigt aber im zweiten Durchlauf 01 0C:00 I 80B9 F2 --> 72 # 0000:0001
Also bringt er wohl was mit der Blockidentifizierung durcheinander.

Die anderen Module M011 64K, M035 1M, M035 1Mx4 laufen da ohne Fehler durch.
Das verunsichert mich doch etwas. Ist das beim M036 ein Fehler auf meiner Platine oder bei diesem Modul immer so und OK?


--
ich brauch es nicht, so sprach der Rabe.
Es ist nur schön wenn ich es habe.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
001
10.09.2018, 05:10 Uhr
ralle



Ich hab bisher immer UniPic dafür genommen. Allerdings kann ich welche nicht Testen, weil das ganze noch in Gera ist.
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
002
10.09.2018, 22:11 Uhr
maleuma



Das rote "I" in den Testausschriften bedeutet, dass die Informationen nicht korrekt gehalten werden. Beim ersten Durchlauf wird zum Schluss ein definiertes Bitmuster eingeschrieben und beim zweiten Durchlauf kontrolliert, ob dieses Bitmuster noch so im Speicher steht.
Es sieht also aus als wären die RAM's nach einer Weile "vergesslich".
--
Mario.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
003
11.09.2018, 04:43 Uhr
edbru



So wird es wohl sein.
Wenn ich nur das M036 anwähle und beim Refreshtest 10s Warteschleife angebe kommt auch der "I" Fehler.
Verbaut sind 4x HY53C464 als Ersatz für den Hybriden, die benötigen wohl 8 Refreshleitungen (A0-A7).
Das könnte eine Ursache sein.
Wurde in
http://www.robotrontechnik.de/html/forum/thwb/showtopic.php?threadid=13546&highlight=m036? mal angesprochen ohne dann darauf einzugehen.

Gibt es auch 64Kx4 RAM die nur 7 Leitungen benötigen die der Z80 ja nur liefert?
--
ich brauch es nicht, so sprach der Rabe.
Es ist nur schön wenn ich es habe.

Dieser Beitrag wurde am 11.09.2018 um 04:45 Uhr von edbru editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
004
11.09.2018, 06:14 Uhr
edbru



sorry für die Postorgie, das mit dem Link wollte nicht klappen.

Ja, das liegt wohl am fehlenden Refresh von A7.
Die Fehlerrate hängt direkt von der Wartezeit beim Refreshtest ab.

Aber das wäre doch ein allgemeines Problem. Müssten den Fehler nicht alle haben, die die Ersatzlösung mit den vier 41646 einsetzen?

Gruß
Eddi
--
ich brauch es nicht, so sprach der Rabe.
Es ist nur schön wenn ich es habe.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
005
11.09.2018, 19:47 Uhr
ralle



Der Ulli hat sich Mal intensiv mit dem 128K-Modul beschaftigt. Ist alles auf seiner Website beschrieben.
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700

Dieser Beitrag wurde am 11.09.2018 um 19:48 Uhr von ralle editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
006
13.09.2018, 07:16 Uhr
Bert



Für den internen Speicher des KC85/4 gibt es die Erweiterung der Refresh-Adress-Bits:
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
007
13.09.2018, 08:32 Uhr
edbru



Danke für den Tip. Deshalb laufen auch die 256K im Grundgerät ohne weitere Änderungen.
Aber auf die Modulschächte kommen nur die normalen Adressleitungen und somit nur der Refresh bis A6.
Da muss ich mir mal einen A7rf selber basteln.
Mich wundert nur dass da noch niemand Probleme mit hatte. Auch auf Ullis Seite, wo die Zusatzplatine beschrieben ist, wird das nicht mal ansatzweise erwähnt.

Gruß
Eddi
--
ich brauch es nicht, so sprach der Rabe.
Es ist nur schön wenn ich es habe.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
008
13.09.2018, 19:15 Uhr
ralle



Ich habe das nur der Vollständigkeit halber, sonst läuft alles über die M035*4., Weil da maximaler Ausbau.
--
Gruß Ralle

Wenn Sie dazu neigen, Bedienungsanleitungen zusammen mit dem Verpackungsmaterial wegzuwerfen, sehen Sie bitte von einem derart drastischen Schritt ab!...
... Nachdem Sie das Gerät eine Weile ausprobiert haben, machen Sie es sich am besten mit dieser Anleitung und ihrem Lieblingsgetränk ein oder zwei Stunden lang in Ihrem Sessel bequem. Dieser Zeitaufwand wird Sie dann später belohnen...

aus KENWOOD-Bedienungsanleitung TM-D700
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
009
14.09.2018, 01:29 Uhr
Enrico
Default Group and Edit


Ich dachte, dass es von dem D-RAM-Modul ein Datenblatt geben würde?
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
010
15.09.2018, 00:30 Uhr
robbi
Default Group and Edit
Avatar von robbi

Als ich vor 13 Jahren den Hybridschaltkreis nachempfunden hatte, habe ich gesehen, der RAM ist da und gut. Einen Speichertest habe ich damit nie gemacht.
Die Wahrscheinlichkeit, daß es am Refresh liegt, ist sehr hoch.
Intern werden in dem Hybrid-IS 2164 eingesetzt. Ich hätte mir meinen Ersatz doch genauer ansehen müssen. Da kann ich nur um Verzeihung bitten und Asche auf mein Haupt streuen...
--
Schreib wie du quatschst, dann schreibst du schlecht.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
011
15.09.2018, 00:58 Uhr
Enrico
Default Group and Edit


Das ist dann aber schon komisch, dass noch keiner von denen geschrien hat,
die sich diese Adapterplatine zugelegt hatten.
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
012
15.09.2018, 01:03 Uhr
Enrico
Default Group and Edit


Bei dem hier von TI ist es schon mal so:

https://restore-store.de/home/96-dram-4464-texas-instruments.html
--
MFG
Enrico
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
013
15.09.2018, 07:56 Uhr
karsten

Avatar von karsten

Hallo robbi und Enrico,
ich glaube zu wissen, dass es die 64k-DRAM mit 7Bit und welchen mit 8Bit Refresh gibt.
Beim U 2164 steht im Datenblatt 128 Refreshzyklen, womit der 7-Bit Refresh hat.
in wiki https://en.wikipedia.org/wiki/Memory_refresh weiter unten bei CPU-based refresh
geht man auf den Z80 und sein 7-Bit-Refresh ein
Gruß
Karsten
--
1. Grundgesetz der Messtechnik?
Wer misst misst Mist!
DDR-Schaltkreise, MC80, K1520
Elektronikarchäologie

Dieser Beitrag wurde am 15.09.2018 um 08:45 Uhr von karsten editiert.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
014
15.09.2018, 10:45 Uhr
kaiOr

Avatar von kaiOr

Laut gedacht:
1. Signal 17 (/RFSH) über D08D negieren und damit jeweils an einen Eingang von D13A und D13C gehen.
2. Signal 59 (CAS0) und 60 (CAS1) auftrennen und jeweils durch D13A und D13C schleusen.
3. Hoffen und beten, dass der RAM fortan den internen Counter zum Refresh verwendet.

Ich kann es leider nicht testen.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
015
15.09.2018, 12:19 Uhr
robbi
Default Group and Edit
Avatar von robbi

@ Enrico (011)
Denen geht es so wie mir: aufbauen, funktioniert auf den ersten Blick, fertig.

Einsetzen wird den Modul wohl niemand so richtig, bei Modulgrößen von 1 und 4 MB.
--
Schreib wie du quatschst, dann schreibst du schlecht.
Seitenanfang Seitenende
Profil || Private Nachricht || Suche Zitatantwort || Editieren || Löschen
Seiten: -1-     [ Technische Diskussionen ]  



Robotrontechnik-Forum

powered by ThWboard 3 Beta 2.84-php5
© by Paul Baecher & Felix Gonschorek